Marcin Barabasz

imagination is more important than knowledge… A. Einstein

module not found: com.typesafe.sbteclipse#sbteclipse-plugin;2.5.0

Leave a comment

If you’ve ever came across this error:

[warn]  module not found: com.typesafe.sbteclipse#sbteclipse-plugin;2.5.0
...
[warn] ::::::::::::::::::::::::::::::::::::::::::::::
[warn] :: UNRESOLVED DEPENDENCIES ::
[warn] ::::::::::::::::::::::::::::::::::::::::::::::
[warn] :: com.typesafe.sbteclipse#sbteclipse-plugin;2.5.0: not found
[warn] ::::::::::::::::::::::::::::::::::::::::::::::
...
[warn] Note: Some unresolved dependencies have extra attributes. Check that these dependenc es exist with the requested attributes.
[warn] com.typesafe.sbteclipse:sbteclipse-plugin:2.5.0 (scalaVersion=2.10, sbtVersion=0.13)
[warn]
[warn] Note: Unresolved dependencies path:
[warn] com.typesafe.sbteclipse:sbteclipse-plugin:2.5.0 (scalaVersion=2.10, sbtVersion=0.13) (C:\development\WorkspaceSTS\HelloScala\plugins.sbt#L3-4)
[warn] +- file-searcher:file-searcher_2.10:0.1
[trace] Stack trace suppressed: run last *:update for the full output.
[error] (*:update) sbt.ResolveException: unresolved dependency: com.typesafe.sbt eclipse#sbteclipse-plugin;2.5.0: not found

Make sure that your plugins.sbt is in fact in project subfolder, and not in project root. This seems like common mistake.

Proper project structure should be:

my-app
|-- build.sbt
`-- project
    |-- build.properties
    |-- plugins.sbt
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s